警告:THE POM FOR COM.ALIBABA:DRUID:JAR:1.1.21 IS INVALID, TRANSITIVE DEPENDENCIES (IF ANY) WILL..

作者: adm 分类: java,mybatis 发布时间: 2021-08-06 09:36

在我对集成DRUID的SPRINGBOOT项目进行打包部署的时候,报了一个警告:

The POM for com.alibaba:druid:jar:1.1.21 is invalid, transitive dependencies (if any) will not be available, enable debug logging for more details

错误如下图所示:
在这里插入图片描述

此时,我检查了一下我java的JDK版本为1.8,环境没问题
此时我考虑可能是用的druid版本太高了,于是尝试降了一下级

driud的依赖从1.2.21降到1.2.20及以下

      <!-- https://mvnrepository.com/artifact/com.alibaba/druid -->
        <dependency>
            <groupId>com.alibaba</groupId>
            <artifactId>druid</artifactId>
            <version>1.1.20</version>
        </dependency>

改了依赖后,果然不报警告了!!!

如果觉得我的文章对您有用,请随意赞赏。您的支持将鼓励我继续创作!